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We are going to determine the phases present in a
mixture and then refine that mixture
• These exercises will remind you of what we did previously and
demonstrate a few extra features
•
1.
2.
3.

The steps for this exercise:
Enable the COD database
Determine what phases are present in this sample
Perform a Rietveld refinement of the mixture

Adding a Database to HighScore Plus
• The free COD database
was downloaded from
http://www.crystallograp
hy.net/new.html
– Alternatively, you may
have installed the
ICDD PDF4 database

•
•
•
•

In HighScore Plus, go to menu Customize > Manage Databases
Click on Add HighScore Database
Navigate and select the COD database with a *.hsrdb extension
Make sure that the Use column is checked
– If the Writable column is checked, you will be able to add your own
entries to the database

Phase Identification: fit the background
1. Open the file “hydrated abalone.xrdml”
2. Fit the background
–
–

Set the y-axis to square root scale
Select menu Treatment > Determine Background…
•
Use Granularity between 10 to 30
•
Use Bending Factor 0 or 1
•
Click Accept;
–

never ever Subtract the background
»
Unless you really want to

Phase Identification: Peak Search
3. Locate the diffraction peaks
–
–

–
–

Select menu Treatment > Search Peaks…
Use the “Identify” parameter set
•
Click on the More button
•
Select Identify from the drop-down menu
Click on the Search Peaks button
Evaluate the Results
•
Modify the search parameters and click Search Peaks again
•
If the search results are good, click on the Accept button

Phase Identification: Run the Search & Match
• Run the phase identification Search & Match algorithm
• Select menu Analysis > Search & Match > Execute Search & Match
–

Use the “Default” parameter set to start
•
Click on the More button
•
Select Default from the drop-down menu

We are going to create a Search & Match routine that only
retrieves reference patterns that contain crystal
structures that can be used in our Rietveld refinement
•
•
•
•
•

Click on the Restrictions tab
Select the Restriction set radio button
Click on the Edit Restriction Sets
button
In the new window that opens, select
the Quality tab,
Check “Skip patterns without structure
data”
– You might also want to check
• Skip non-ambient temperature
• Skip non-ambient pressure

•

Save the Restrictions Parameter Set
– Click on the floppy disk icon

•
•

Click Close
Save the Search & Match Parameter
Set
– Click on the floppy disk icon

Phase Identification: Determine Good Matches
• Click on the Search button
• Click OK when the search is done
• Look through the candidate list and determine if any of the highest
scored phases are a good match
• If they are, then move them to the Accepted Pattern list
• The program automatically rescores the candidates
– you should find another match at the top of the newly resorted
candidate list

• Once you have identified all of the relevant phase, clear the
candidate list
– Right-click in the candidate list
– Select “Remove All Candidates”
– This will speed up the program

Need more help with Search & Match procedures?
• In the HELP, look under the Quick
Start Guide
– Performing Search-Match Identify
– Phase Identification Strategy
– You may also have a printed copy
of the Quick Start Guide

• In the HELP, look under Analysis >
Phase Analysis
• Online, look at
http://www.icdd.com/resources/tutori
als/
– Data Mining- Trace Phase Analysis
– Other tutorials

Refining a sample with two phases present
• Our Phase ID shows that both aragonite and calcite phases are
present
• Set refinement mode to “Semi-Automatic”
• We need to transfer the crystal structures from the reference cards
into our refinement control
– In the Pattern List, select both phases
• Select multiple phases by using Shift + Click
– Right-click in the Pattern List and select “Convert Pattern to Phase”
– Select Refinement Control in the Lists Pane
• You will see that aragonite and calcite have been entered into the
refinement control

Global Parameters in the refinement will affect
both phases
• The Global Parameters will affect both phases
– background
– specimen displacement or zero shift
– POL correction

• Phase parameters are refined separately for each phase
• We are going to use the background that we manually fit in order to
make the refinement a little easier
– Select Refinement Control tab in the Lists Pane
– Click on “Global Variables”
– In the Object Inspector, under Background set the method to “Use
Available Background”
– This approach works very well for complex mixtures or diffraction
patterns that have a lot of overlapping peaks

Shortcut for refining parameters from multiple
phases
• Right-click on any field in the Refinement Control list
• The “Refine All” and “Fix All” choices will set refinement of a
parameter for all of the phases loaded into the refinement model
• Remember, you can use “Show Refined Values/Constraints...” to
keep track of all of the parameters that are currently being refined

The refinement of multiple phases proceeds
similarly to that of single phases
1. Refine the scale factor for both aragonite and calcite
1. Right-click on any field in the Refinement Control list
2. select Refine All > Scale Factors
3. Click on the Start Rietveld Refinement button

2. Refine ‘Specimen Displacement’ to adjust peak positions
1. In the Global Variables field of the Refinement Control list, put a check
mark next to Specimen Displacement
2. click on the Start Rietveld Refinement button

Excluding problematic regions to improve the
refinement
• Background at high angles doesn’t fit so well
• we can either try fitting it or ignore it
• We will ignore it
– Select menu Analysis > Rietveld > Edit
Excluded Regions
– Click New Region
• type 68 for start
• type 70 for end
– click OK

• Run the refinement again without adding
additional refinement terms

Refining parameters for individual phases requires
some consideration
• Refining Lattice Parameters– should the sample have similar or
different lattice parameters from those in the initial crystal structure?
– this sample is from the shell of abalone, a sea snail
– crystal structures from NBS data for synthetic analogues to the mineral
– it would be reasonable for the lattice parameters to be slightly different

• If the lattice parameters from the initial structure should be accurate
to the sample in consideration, then maybe refine the profile
parameters before refining the lattice parameters
• In this case, we will refine the lattice parameters for both phases
– right-click in the Refinement Control list
– select Refine All > Cells

Refining peak profiles in multiphase samples should be
done cautiously if there are a lot of overlapping peaks
• Sometimes, Rietveld refinement code will make the peaks from one
phase very wide
– The code is trying to use a wide peak from phase 1 to account for
intensity from phase 2
– Sometimes, the code tries to improve a poor fit to the background by
making the diffraction peaks very wide

• refine W, V, and U for both phases
– refine each Cagliotti peak width parameter one at a time
– again, using the “Refine All” and “Fix All” options can save a lot of time

• refine Peak Shape Parameter 1

Evaluate the Quality of the Refinement
• Evaluate the refinement
– how good is it?
– The Weighted R profile is ~22%
• The R expected is 2.6%
– when you click on a phase name in the Refinement Control list, you will
see a highlighted trace emphasizing that phase alone
• If this does not work, select menu View > Display Mode > Show
Selected Phase Profile

Problems with Refinement
•

Aragonite
– peaks at 31deg (002) and 33deg (012) for aragonite do not have
enough intensity
– suggests [002] preferred orientation

•

Peak profiles do not vary properly
– high angle peaks in experimental data are sharper than as fit with
simulation

•

If you refine B Overall for both samples, the B for calcite is much larger than
for aragonite
– this sort of thing often suggest sample preparation problems

•

For all of these problems, once the preferred orientation is accounted for the
calculated weight fractions for the mixture is good

Let’s refine another sample
1. In Refinement Control, right-click and select Fix All > Refined
Parameters
2. Select the Scan List
3. Right-click on the scan and select Remove Scan
4. insert dry abalone.xrdml
1. Select File > Insert

5. Fit the background
1. Select Treatment > Determine Background

6. Select the Refinement Control List
1. Both phases are still present in the Refinement Control List

7. Refine scale factor for both phases
8. Refine specimen displacement
• without much work, what do we learn about this sample?

• If we were interested in investing more time for this analysis, a good
approach would be:
– refine the aragonite structure in the dry abalone data file, since the
single phase sample will be much easier to refine than the mixture
– feed the phase parameters (lattice parameters, preferred orientation, B
overall, profile parameters, etc) for aragonite from the single phase dry
abalone sample into the refinement of the mixture in hydrated abalone
sample

Using Automatic Rietveld Refinement in HSP
• We are going to refine PbTiO3 data using an automated batch
• Open “PbTiO3 RT.xrdml”
• Instead of creating a crystal structure from scratch, we are going to
load a crystal structure from an external file
– go to File > Insert
– select PbTiO3.cry
• the *.cif format is more common for data downloaded from online
journals and databases
• the cry format can be created by HSP and can contain multiple
crystal structures
– The PbTiO3.cry file contains the crystal structures for both tetragonal
and cubic forms of PbTiO3
– load just the tetragonal form

Automatic Rietveld Refinement
• You can use automatic fitting to progress through the initial
refinement steps without having to do it all manually
• Set up automatic Rietveld Refinement
– Analysis > Rietveld > Edit Automatic Rietveld Steps

• You can reorder steps in the Automatic Rietveld program by drag
and dropping
• Check the “Used” column to indicate if that step will be executed or
not
• there are additional details for each step that can be modified
– the biggest choice for all of the is the “Switch off after usage” flag, which
determines if that parameter continues to be refined as refinement
proceeds to the next step or if it fixed during all subsequent steps

• Click the More>> button to see the controls for loading parameter
sets and for saving your custom parameter set

Automatic Rietveld
•

Parameters in the Automatic Rietveld program
1. Scale Factor:
continue refining this parameter as
• SwitchOffAfterUsage: False
additional parameters are also refined
2. Flat Background:
• SwitchOffAfterUsage: False
only refine one or the
other; specimen
3. Zero Shift:
displacement is almost
• Refine Specimen Displacement Instead: True
always the better
choice
• SwitchOffAfterUsage: False
many parameters should not be refined
4. Lattice Parameters:
for trace phases because the peaks are
• Minimum Weight Percentage:5
too weak; -1 means no minimums are
applied
• SwitchOffAfterUsage: False
5. More Background:
• No. of Additional Background Parameters: 2 (can be 1-5)
• SwitchOffAfterUsage: False

6. W (Halfwidth)
• Minimum Weight Percentage: 5
• SwitchOffAfterUsage: False
7. U, V (Halfwidth)
• Minimum Weight Percentage: 10
if you have instrument parameters for initial
• Refine U: True
u, v, and w values, then consider not
refining v; especially if evaluating
• Refine V: True
nanocrystallite size
• SwitchOffAfterUsage: True
8. Peak Shape Parameters
• Minimum Weight Percentage: 10
• No of Parameters: 1
• Refine Anistropic Broadening: False
• Refine Asymmetry: False
• SwitchOffAfterUsage: True
9. Site Occupancy factor and B isotropic
don’t automatically refine values
• Minimum Atomic Number: 20
for light elements
• Minimum Weight Percentage:10
• Refine Mixed Sites: False
• SwitchOffAfterUsage: False
• Use Overall B: True

• Save the Automatic Rietveld parameter set
– button in the lower right corner might say “More”
– click on this button to see the options for saving the parameter set
– click on the floppy disk icon to save the parameter set

• To run the Automatic Rietveld refinement using the saved parameter
set
– set the Refinement mode to “Automatic Mode”
– click on the drop-down menu next to the “Start Refinement” button
– choose the parameter set that you saved

• The automatic mode refinement gets us 95% of the way to the
solution with this example
– the weighted R profile is near 10%

• This approach can be very effective for routine quantitative phase
analysis
• To improve the refinement, we could change the refinement mode to
semi-automatic mode and do some manual refinements
– the biggest improvement would come from refining some of the profile
parameters together and by refining the asymmetry parameter

1. Crystallite Size Analysis
1.
2.
3.
4.

Refining an instrument profile standard
Using the result to create a template
Refining a nanocrystalline sample
Improving the refinement by using LeBail fitting

Using a template for nanocrystallite size analysis
• We are going to refine a Ceria (CeO2) standard
• This will be used to determine the U, V, and W that is characteristic
for the instrument profile of our diffractometer
• We will use the result to create a template that can then be used in
the analysis of nanocrystalline Ceria
• Open Ceria Standard.xrdml
• Insert Ceria Structure.cif
• Refine the model

Use the results of the previous refinement to
create instrument profile parameters
•

In the Refinement Control list, rightclick on the phase name
– you need to click on the phase
name, not on any other field
– select “Take as Size-Strain
Standard”
– this exports the U, V, and W
values into the Global
Parameters object as U
standard, V standard, and W
standard
– these values will be used to
determine how a sample profile
is broadened due to crystallite
size and/or microstrain

A template can be used as a starting point for
multiple analyses of experimental data
• You could record the Caglioti coefficients from the Instrument
Standard field and them enter into every new document
– If you are not sharing a computer and only use one instrument with one
configuration, you could also save them as defaults in the menu
Customize > Defaults

• In order to save work, you can also create a template file
– A template file is an empty HPF document that contains several settings
– We will create a document that contains the Caglioti coefficients
determined by the analysis of the standard
– A template can also contain
• Reference patterns
• Peaks in the peak list
• Phases for refinement

Creating a template
• After you create the Size-Strain Standard
– Go to the Peak List tab in the Lists Pane
• Right-click in the Peak List and select the menu option Delete >
Included Peaks
– Go to the Refinement Control tab in the Lists Pane
• Expand the entries Global Variables and Background
• In every parameter within Background (Flat Background, Coefficient
1, etc), set the value to 0
• Remove the Phases if your specimen is a different material
– Go to the Pattern List in the Lists Pane
• Delete all reference patterns loaded in the Pattern List
• If you are always analyzing the same phase(s), you could load the
reference patterns for those phases and save them in the template
– Go to the Scan List in the Lists Pane
• Delete all experimental scans loaded in the Scan List

• Save the document in a *.HPF format with a clever name like “LP
Analysis Template.hpf

To determine the crystallite size, you need to specify the
sample broadening analysis for each phase
• To analyze the nanocrystalline specimen, insert the file “ceria
nanophase.xrdml” into the template file
• Go to the Refinement Control list
• Click on the phase name for the ceria structure
• In the Object Inspector, find the Phase Profile area
• In the field Size Strain Analysis, from the drop-down menu you
should select either “Size Only” or “Size and Strain”

Refine the sample to determine the crystallite size
• The Cagliotti parameters will be used to determine how size and
strain creates broadening of the sample
– V will not be refined
– U and W will be refined according to the Size-Strain analysis specific in
the phase settings

• After refinement, you can find the calculated size and/or strain from
in the Object Inspector for the phase, under Derived Data

Templates can be used to facilitate analysis of a
number of sample types
• For QPA of mixtures, refine a mixture and save the result as a
template
– this will preserve the refined lattice parameters, peak profiles
parameters, and preferred orientation coefficient
– using this as a starting point for analysis of similar mixtures can make it
faster

Fixing the ceria refinement using LeBail
(structureless) fitting
• Because of poor sample preparation, the intensity does not vary
properly as a function of 2theta
– the experimental intensity at large angles 2theta are incorrect

• We can accurately determine lattice parameters and crystallite size
broadening even if the intensity is off
– this assumes that the errors affecting intensity do not affect the peak
positions or peak profiles

• To fit data with a systematic error in intensity, we will arbitrarily fit the
intensity of each peak
– instead of calculating the intensity from the structure factor from the
crystal structure of the phase

To start the LeBail fit
• click on the phase name in the Refinement Control list
– In the General Phase Info field of the Object Inspector change the fitting
mode from Structure Fit to Le-Bail Fit

• Right-click on any field in the Refinement Control list
– select “Fix All”
– select “Refined Parameters”

• Run a refinement in Semi-automatic mode
• This iteration of refinement is used to fit the intensity of each
individual peak
– peak positions and peak profiles are still constrained by the parameters
of the phase, such as lattice parameter and Cagliotti parameters

Preferred Orientation
• First, identify the direction of the
preferred orientation
– Begin the Rietveld refinement of the
data
– Turn on (hkl) labelling of peaks
• Right-click in the Main Graphics
window and select Label Peaks
• In the Label Peaks dialog, select
HKL
• Click OK
• The peaks will now be labelled
• This only works if the calculated
pattern has been simulated or
refined

Preferred Orientation
• Look at the (hkl) values for obvious
trends in intensity vs. geometry
– Remember that (hkl) is parallel to (n*h
n*k n*l)
– For example, (011) and (022) are
parellel
– In the plot to the right, the (011) and
(022) peaks are both stronger than
calculated
– All other peaks are weaker than
calculated
– This indicates a [011] preferred
orientation
– Sometimes a related set of peaks will
be weaker rather than stronger; this
corresponds to a needle-like particle
shape

Defining Preferred Orientation with the MarchDollase function
• March-Dollase is defined assuming one
axis is fixed in its orientation and the other
two axes have freedom of rotation
– If the March-Dollase parameter is <1, then
the fixed axis is normal to the surface of the
sample (parallel to the diffraction vector s)
and [hkl] is defined as the fixed axis which
will produce diffraction peaks stronger than
otherwise predicted
– If the March-Dollase parameter is >1, then
the fixed axis is parallel to the surface of the
sample (normal to the diffraction vector s)
and [hkl] is defined as the fixed axis which
will produce diffraction peaks weaker than
otherwise predicted

Set the preferred orientation direction in the Object
Inspector window for the selected phase

Flag the preferred
orientation parameter to
refine here

Set the preferred
orientation direction
here

