Fundamentals of Rietveld Refinement
II. Refinement of a Single Phase

An Introduction to Rietveld Refinement
using
PANalytical X’Pert HighScore Plus v3.0a

Scott A Speakman, Ph.D.
MIT Center for Materials Science and Engineering
speakman@mit.edu
The Rietveld Method

1. The parameters previously discussed are used to create a model
2. A diffraction pattern is calculated from the model
3. The calculated pattern is compared to the observed data
4. The differences between the observed and calculated patterns are minimized by varying parameters in the model through a least squares process
5. When the calculated and experimental diffraction patterns match, the model may represent the original sample

- The Rietveld Method requires:
  – high quality experimental diffraction pattern
  – structure model that makes physical and chemical sense
  – suitable peak and background functions
There are several places to configure HSP settings before beginning a refinement

- Select a preconfigured or custom desktop
  - go to View > Desktop to select a desktop
  - the “Structures” desktop is well suited for Rietveld refinement
  - a quirk of HSP: imagine that the “Structures” desktop was selected but was then changed. In order to reset to the desktop to the “Structures” layout, you need to select another desktop and then select the “Structures” desktop again

- In Customize > Defaults you can set the starting values for several XRD pattern simulation parameters
  - Default Instrument Settings
    - Change these if you are routinely analyzing data that were not collected with a PANalytical diffractometer
  - Default Global Settings
    - Set the Background Method to the type you most often use (polynomial, use available background)
    - Set the Profile Base Width (in Refinement) to 8 or more
Program Settings contains several options important for Rietveld Refinement

- Go to the menu Customize > Program Settings
  - Click on the button Reset All to Default to change parameters to the default behavior.
  - After doing this, you might want to change a couple of settings to be better optimized for Rietveld analysis
- In the General tab
  - Set Auto-save time and Number of Undo/Redo steps as you like
  - Adding more undo steps will slow down the program
- In the Rietveld tab
  - check “Show selected Phase Profile”
  - check “Calculate Correlation Matrix”
  - Check “Keep R-value Graphics Open after Refinement”
  - Check “Undo Refinement Control Editing”
Do not process the data before Rietveld refinement

• Do not subtract the background before refinement
  – The background will be modeled during the Rietveld analysis

• Do not strip K alpha-2 peaks before refinement
  – The K alpha-1 and K alpha-2 peak doublet will be modeled by the profile function

• Do not smooth the data before refinement
  – Rietveld refinement relies on a statistically comparison to your raw data which will be invalid if your data are smoothed

• The only processing you should consider is converting ADS data to FDS
You must define the instrument parameters and correct your data if variable slits were used

- The Divergence Slit Type is reported in the Object Inspector for the Scan
  - In the Lists Pane, select the Scan List tab. This will load scan information into the Object Inspector
  - In the Object Inspector, scroll down to the Instrument Settings area
  - If your data were collected with a PANalytical instrument, these values are already defined
  - If your data were not collected with a PANalytical instrument, you should input the correct Divergence Slit Type, Anode Material, and Goniometer Radius
    - The Divergence Slit Type is:
      - Fixed for a fixed divergence slit aperture
      - Automatic for a variable divergence slit aperture

- If your data were collected using variable divergence slits, you must correct for the constant volume assumption
  - Variable slits are the Programmable Divergence Slit (PDS) in “Automatic Mode” on the PANalytical X’Pert Pro
You must correct your data if they were collected using variable divergence slits

- If your sample was ‘infinitely’ thick, then the irradiated volume was increasing. This can be corrected in HighScore Plus.
  - Select the menu **Treatment > Corrections > Convert Divergence Slit**
  - Load the default parameters
  - Click the **ADS to FDS** button
  - Click the **Replace** button
  - Click the **Close** button

- If your sample was thin, then the irradiated volume was constant. In this case, you must change the instrument setting for your data in HighScore Plus.
  - In the Lists Pane, select the **Scan List** tab. This will load scan information into the Object Inspector
  - In the Object Inspector, scroll down to the Instrument Settings area.
  - In the entry for Divergence Slit Type, change it from Automatic to Fixed.
    - This will tell HighScore Plus that your data fulfilled the constant volume assumption, even though variable slits were used.

- If your sample was thin and you used fixed divergence slits, then the data cannot be analyzed by Rietveld refinement because they do not fulfill the constant volume assumption.
To load in a crystal structure model for refinement

• You can manually enter the crystal structure as detailed in Part I of this tutorial
• You can download a *.cif file from an online database (such as http://www.crystallography.net/) or journal.
  – Then, go to File > Insert to load the *.cif structural information into your data.
• You can search the database linked to HighScore Plus (such as PDF4, ICSD, or COD) for your reference card
  – In the Quality tab of the Restrictions dialogue, be sure the check “Skip patterns without structure data”.
  – This will guarantee that all reference patterns you retrieve contain crystal structure information
The reference card must be converted before you can use it as the starting basis for unit cell refinement

- After you have loaded the reference card(s), go to the Pattern List tab in the Lists Pane
- Right-click on the phase(s) that you want to refine
- Select “Convert Pattern to Phase” from the menu
- The reference(s) that you converted are now listed in the Refinement Control tab of the Lists Pane
Starting a Refinement

- **Calculate the diffraction pattern**
  - click the “Start Pattern Simulation” button in the Rietveld toolbar, or
  - Select *Analysis > Rietveld > Start Pattern Simulation*

- the total intensity will not match because the scale factor is wrong

- make sure that peak positions match up approximately

- To change the range calculated in the simulation:
  - Go to menu *Customize > Program Settings*
  - Select the *Simulation* tab
  - Change parameters and click *OK*
The Semi-Automatic Refinement Mode gives you control over which parameters are refined.

- Set the Refinement to **Semi-automatic Mode**
  - Use the drop-down menu in the Rietveld toolbar
  - Use the drop-down menu in the menu *Analysis > Rietveld > Refinement Mode*

- How to flag parameters for refinement
  - In the Lists Pane, select the Refinement Control tab
  - To mark a parameter for refinement, put a check mark next to the parameter in the ‘Refine’ column
  - Then click on the “Start Rietveld Refinement” button
Define how the background will be fit

- You must decide how you are going to fit the background
  - You could manually fit the background and use that during the refinement
  - You could fit the background using a polynomial or other equation and allowing the background parameters to refine during the Rietveld refinement

- To change the background method
  - In the Refinement Control Lists Pane, select Global Variables
  - In the Object Inspector, select an option from the drop-down menu for the Background Method
    - This menu is near the top of the list in the Object Inspector
When you begin a refinement, you do not want to refine too many parameters at the same time

- When we begin the refinement, we refine only a few parameters simultaneously
- If you refine too many parameters at the same time, the refinement will diverge
  - i.e. blow up, go crazy, fail
- Remember, the computer is guided by numbers, not by common sense
  - The computer only cares about minimizing the least-square residual
  - for example, the computer could begin shifting the peak positions, intensities and widths in order to fit the background if we refine those parameters before getting a good background fit

The computer thinks this is the beginning of a good refinement
1. **First, refine only the Scale Factor**
   - Put a check mark next to Scale factor
   - Click on the Start Refinement button

   • The calculated peak intensities should now match the experimental data
     - The calculated peak intensities may be different if there is substantial peak shift, so that the calculated peak positions do not match the observed peak positions
Refine the background, adding one additional term at a time

2. Scale Factor + Flat Background
   – sometimes it helps to change the y-axis to square root scale to better evaluate the background fit

3. Scale Factor + Flat Background + Coefficient 1

4. Scale Factor + Flat Background + Coefficient 1 + Coefficient 2

5. Scale Factor + Flat Background + Coefficient 1 + Coefficient 2 + 1/X Background
   – The increase in background at low angles of 2theta can be well modeled using the 1/X Background term
How to tell if the refinement is proceeding well

• **First, look at the data**
  – If the peak positions fit fairly well at this point, continue improving the background fit
  – If the peak positions don’t fit well at this point, refine peak positions starting with specimen displacement
  – based on the result that we see, the calculated peak position is slightly too high

• set Additional Graphics to show ‘Difference Plot’
  – go to View > Additional Graphics > Difference Plot
  – This plot will show the difference between the observed and calculated diffraction patterns
Also Use Agreement Indices to Evaluating the Refinement

- The Agreement Indices quantify how well the calculated XRD pattern fits the experimental data
  - Click on “Global Parameters” in the Refinement Control list
  - The Agreement Indices are shown in the Object Inspector
- $R_{expected}$ shows the best possible value for the Residual
  - A lower $R_{expected}$ value indicates higher quality data
- $R$ profile and Weighted $R$ profile show how well the calculated pattern matches the experimental data
  - we want the Weighted $R$ profile to be less then 10% and as close to the $R$ expected value as possible
  - $R$ expected is an estimation of the best possible $R$ profile based on the statistical noise of the experimental diffraction pattern
- GOF (goodness of fit) is $wR_p/R_{exp}$.
  - This should approach 1
  - GOF is more and more irrelevant because modern detectors mess up the statistical validity
We need to refine the peak position

5. Previous parameters + Specimen Displacement
   - The lattice parameter of LaB6 is well known, so peak shift is most likely due to either specimen displacement or zero shift error
     • displacement- peak shift varies as $\cos \theta$
       \[ \Delta 2\theta = -\frac{2s \cos \theta}{R} \text{(in radians)} \]
     • zero shift- peak shift constant vs $\theta$
     • never never never refine both at the same time!!!

   • Usually you should refine lattice parameter next, but we can see that the peak width is the more significant error
With peak positions and background fit well, begin refining peak profiles

- keeping all previous parameters checked, start refining profile parameters
  - we keep refining the peak position parameters because as the peak width and shape changes the peak position may change in response
  - initially, we only refine 1 profile parameter at a time
    - if we try refining too many too soon, the refinement will diverge

6. start refining Cagliotti parameters one at a time
   a. W only
   b. V only
   c. U only

7. refine Peak Shape 1 (not refining any Cagliotti parameters)

8. look at the lowest angle peaks to determine if you need to refine the peak profile asymmetry
   - in this case, we do need to refine the asymmetry parameter
   - Repeat steps 6-8, refining parameters one at a time, a few times
• look at high angle peaks (88°) - note how Kα1 and Kα2 are both modeled
  • If the Kα2 ratio is off, you may need to change the polarization correction
  • To find POL values, look in help (search keyword polarization)
    • these data were collected using a Ni beta filter, so POL=1
  • values are entered by:
    • click on Global Parameters (in Refinement Control list)
    • in Object Inspector, find Polarization Correction Coefficient under General Properties
    • in this case, it is correctly set to 1

• look at a low angle peak (30.5°)
  – note how the peak profile is truncated
  – not much of a problem for this data set, but for others it might greatly compromise the refinement
  – change values:
    • click on Global Parameters (in Refinement Control list)
    • in Object Inspector, find Profile Base Width under Refinement
    • change to 8, rerun refinement
    • can change “permanently” in Customize > Defaults ...
The peak positions are slightly off, so we need to refine lattice parameters

- Look at the high angle peaks; the positions are slightly off
- Even though the LaB6 lattice parameters are well known, we need to refine the lattice parameters anyway
- Refine the lattice parameter a
  - b and c will refine automatically
In addition to Agreement Indices, we can look at estimated standard deviation to evaluate the precision of refined parameters

- Look at columns: value, deviation, maximum, minimum, Use Min/Max, Constraint, Last Shift
  - I usually rearrange the columns in the order shown below (just drag and drop the column headings)
  - The small deviation value for the lattice parameter indicates that the refinement is fairly stable and that we are approaching a good solution
• In the Refinement field of the Global Parameters Object, seen in the Object Inspector pane, we can also view and change
  – Several limits are used to speed up the refinement calculation
    • Profile base width: limits the 2theta range over which the intensity contribution of a peak (hkl) is calculated
      – assumes that the intensity contribution from a peak is zero beyond this range
      – the base width values constrain the range in multiples of the FWHM
    • maximum angle of asymmetry correction: peaks below this angle are corrected for asymmetry. peaks above this angle are assumed to be symmetrical
    • intensity limit: Refinement does not calculate or refine using peaks with a calculated intensity less than the intensity limit
  – the profile function used to calculate the shape of all diffraction peaks
  – the Weighting scheme puts greater emphasis on Iobs or Icalc in the refinement residual
  – max. no. of least-square cycles
    • maximum number of times the parameters are refined before the refinement stops (assuming other criteria do not cause refinement to stop)
    • if this number is set too low, the refinement may cease before the parameters are truly optimized
    • if this number is set too high, the refinement may take much longer than necessary or may be unstable
before we continue improving the profile fit, let's remind ourselves what is currently being refined

- right-click on any value in the **Refinement Control** list
- choose “Show Refined Values/Constraints ... “
- the table shows us what parameters are currently checked to be refined
To finish the refinement, we need to begin refining multiple profile parameters at the same time

- Peak width and profile parameters are going to affect each other
- for a complex refinement, we would go through several iterations of refining one parameter at a time
  - refine $W$ only, then $V$ only, then $U$ only, then Shape 1 only, then $W$ only, then $V$ only, then $U$ only, then Shape 1 only, then asymmetry only, then $W$ only, then $V$ only, then $U$ only, then Shape 1 only, then asymmetry only ...
  - then begin refining some parameters together at the same time
- Because this is a high quality experimental pattern of a simple and well crystallized sample, we can begin refining multiple profile parameters at the same time
  1. $W$
  2. $W+V$
  3. $W+V+U$
    1. notice large change in these parameters as they influence each other
  4. $W+V+U + $Peak Shape 1
  5. $W+V+U + $Peak Shape 1 + Asymmetry
Let us consider the current refinement
- Weighted R profile $> 10$ and GOF $> 4$, which usually aren’t very good
- visually, it is approaching the “not bad” level of quality

Where is the biggest discrepancy?
- background needs improvement in low angle region
  - try refining flat background + 4 coefficients + 1/x background
  - wRp and GOF both improve
- profiles are good, but not perfect
  - asymmetry of low angle peaks, in particular, needs more refinement
  - the peak asymmetry is actually too much for the simple Rietveld asymmetry correction to model- we need to use the more complicated FJC Asymmetry (an option in profile functions)
  - system has a lot of axial divergence- better than modeling the asymmetry would be to recollect the data using better Soller slits
- most error is from the second phase present in this sample
  - this is NIST 660 LaB$_6$ (not even NIST 660a), famous for its impurities

Consult the values for deviation
- all values are fairly small, showing that the refinement is stable
- a large deviation means that that parameter could vary by a large amount without affecting the quality of the fit, meaning that that value has not been precisely refined
We could aggressively refine parameters at the same time because this is a simple pattern

- Consult the correlation matrix
  - go to Analysis > Rietveld > Show Correlation Matrix
  - notice high correlations
  - values approaching 100% mean that two parameters are highly affecting the refinement of each other
  - refining so many profile parameters simultaneously would not work for more complex sample or lower quality data

![Correlation Matrix Image]
refining thermal parameters

• stop refining all profile parameters
  – right-click to access shortcuts for
    • seeing all parameters currently being refined
    • turning multiple parameters on (refine) or off (fix) at the same time
  – refine B isotropic for La
  – turn off B isotropic for La, turn on B isotropic for B
  – need to refine cautiously
  – need to watch for nonsensical values
    • ie B= 0 or negative value
    • max/min automatically set to allow only a minimum value of 0
    • if B keeps going to zero, it is probably really trying to go negative
      – but the minimum constraint does not let it
Save analyzed data in the HPF format

• Save the result as a *.hpf file
• this file format bundles together the original data, the results of all analyses done on the data, and the history of the data analysis

• you can view the history of data analysis in File > Properties
Using Automatic Rietveld Refinement in HSP

• We are going to refine PbTiO$_3$ data using an automated batch
• Open “PbTiO3 RT.xrdml”
• Instead of creating a crystal structure from scratch, we are going to load a crystal structure from an external file
  – go to File > Insert
  – select PbTiO3.cry
    • the *.cif format is more common for data downloaded from online journals and databases
    • the cry format can be created by HSP and can contain multiple crystal structures
  – The PbTiO3.cry file contains the crystal structures for both tetragonal and cubic forms of PbTiO3
  – load just the tetragonal form
Automatic Rietveld Refinement

- You can use automatic fitting to progress through the initial refinement steps without having to do it all manually.
- Set up automatic Rietveld Refinement
  - *Analysis > Rietveld > Edit Automatic Rietveld Steps*
• You can reorder steps in the Automatic Rietveld program by drag and dropping
• Check the “Used” column to indicate if that step will be executed or not
• there are additional details for each step that can be modified
  – the biggest choice for all of the is the “Switch off after usage” flag, which determines if that parameter continues to be refined as refinement proceeds to the next step or if it fixed during all subsequent steps
• Click the More>> button to see the controls for loading parameter sets and for saving your custom parameter set
Automatic Rietveld

- Parameters in the Automatic Rietveld program
  1. Scale Factor:
     - SwitchOffAfterUsage: False
  2. Flat Background:
     - SwitchOffAfterUsage: False
  3. Zero Shift:
     - Refine Specimen Displacement Instead: True
     - SwitchOffAfterUsage: False
  4. Lattice Parameters:
     - Minimum Weight Percentage: 5
     - SwitchOffAfterUsage: False
  5. More Background:
     - No. of Additional Background Parameters: 2 (can be 1-5)
     - SwitchOffAfterUsage: False

continue refining this parameter as additional parameters are also refined

only refine one or the other; specimen displacement is almost always the better choice

many parameters should not be refined for trace phases because the peaks are too weak; -1 means no minimums are applied
6. W (Halfwidth)
   • Minimum Weight Percentage: 5
   • SwitchOffAfterUsage: False

7. U, V (Halfwidth)
   • Minimum Weight Percentage: 10
   • Refine U: True
   • Refine V: True
   • SwitchOffAfterUsage: True

8. Peak Shape Parameters
   • Minimum Weight Percentage: 10
   • No of Parameters: 1
   • Refine Anistropic Broadening: False
   • Refine Asymmetry: False
   • SwitchOffAfterUsage: True

9. Site Occupancy factor and B isotropic
   • Minimum Atomic Number: 20
   • Minimum Weight Percentage: 10
   • Refine Mixed Sites: False
   • SwitchOffAfterUsage: False
   • Use Overall B: True

if you have instrument parameters for initial u, v, and w values, then consider not refining v; especially if evaluating nanocrystallite size

don’t automatically refine values for light elements
• Save the Automatic Rietveld parameter set
  – button in the lower right corner might say “More”
  – click on this button to see the options for saving the parameter set
  – click on the floppy disk icon to save the parameter set
• To run the Automatic Rietveld refinement using the saved parameter set
  – set the Refinement mode to “Automatic Mode”
  – click on the drop-down menu next to the “Start Refinement” button
  – choose the parameter set that you saved
• The automatic mode refinement gets us 95% of the way to the solution with this example
  – the weighted R profile is near 10%

• This approach can be very effective for routine quantitative phase analysis

• To improve the refinement, we could change the refinement mode to semi-automatic mode and do some manual refinements
  – the biggest improvement would come from refining some of the profile parameters together and by refining the asymmetry parameter